Email To SMS Outage
Incident Report for MessageNet
Postmortem

Summary of the E2S disruption in Australia

November 28th, 2022

We wanted to provide you with some additional information about the service disruption that occurred for messages sent from the Email2SMS platform on November 19th, 2022.

At 11:00 on November 19th, during a planned migration of our Email and Exchange services we identified that mail routing rules had been impacted, introducing a degradation where certain customer mail2sms messages were identified as spam or dropped prior to sending.  This failure resulted in intermittent messages not sending for 19th November 2022 between 10:24 and 17:42.

Normally, our Exchange and mail capabilities have multiple layers of resilience and redundancy to prevent outage and incident. Due to the nature of the planned migration this did not apply and introduced the degradation we identified.

Customer Impact

Between 10:24 and 17:42 AEST on November 19th, Email to SMS (E2S) messages were not delivered.

API and web-portal sending was unaffected.

Recovery

During the deployment the team had received notification that delivery rates had changed outside of expected thresholds which triggered remedial action to identify and resolve the mail routing rules in question and correct. Due to the number of rules and replication needs this contributed to the longer than desired recovery period.

Remediation

While we have experienced optimal operational performance since our change and routing update, it is apparent we need to enhance this migration approach and resiliency moving forward. Whilst this type of activity is not predicted to occur in the near future, further work to ensure greater resiliency and failover is available within this element of the service.

Posted Nov 28, 2022 - 09:56 AEDT

Resolved
Overnight monitoring of the traffic has confirmed that the issue is fully resolved.
We will be conducting a post incident review and will post the details of the PIR once released.
Posted Nov 20, 2022 - 12:18 AEDT
Monitoring
We believe the primary issue has been resolved and we will be monitoring traffic for the next few hours.
Posted Nov 19, 2022 - 19:24 AEDT
Identified
We have identified the cause of the issue and have partially restored the service, however, we are still determining if the current failures we are seeing are related to the primary cause, or from other unrelated factors.
Posted Nov 19, 2022 - 18:55 AEDT
Investigating
We have determined that submissions of Email to SMS messages from external email addresses have been receiving bounce-back error messages since around 10:30 this morning. This has been escalated as critical internally and we are investigating a fix.
Further updates to come.
Posted Nov 19, 2022 - 15:43 AEDT
This incident affected: Gateway, API, Web Portal, and Email to SMS.